Aktivieren von Link Aggregation (LAG) auf Cisco Wireless Access Points

VonJochen Reinecke

Aktivieren von Link Aggregation (LAG) auf Cisco Wireless Access Points

Die Cisco Wireless Access Points (WAP) der Serien 1800, 2800, 3800 unterstützen den Wireless Standard IEEE nach 802.11ac. Somit sind theoretisch  Datenraten von über 1Gbit/s über die Funkfelder möglich. Vernetzt werden Access Points hingegen üblicherweise über 1Gbit/s PoE-fähige Switchports. Damit kein Engpass entsteht, sind die Access Points mit einem zusätzlichen Ethernet-Port (Kennzeichnung: AUX) ausgerüstet. Dieser lässt sich gemeinsam mit der ersten Ethernet-Schnittstelle als Link Aggregation (LAG) zusammenfassen. Cisco unterstützt dabei statische Etherchannel / Port-Channel bzw. jene über LACP (IEEE 802.1AX-2008, früher IEEE 802.3ad).

 

Physische Vernetzung

Das folgende Foto zeigt die Rückseite eines Cisco 2800 Access Point. Während der Ethernet-Port (POE) für die allermeisten Administratoren bekannt sein dürfte, kann nun der als AUX gekennzeichnete Port als sekundärer Ethernet-Port verwendet werden. Dazu einfach die beiden Ethernet Ports am Access Point mit zwei entsprechenden Gigabit-Switchports verbinden und mit der logischen Konfiguration fortfahren.

 

Anpassungen am Wireless Controller

Damit die gängigen Cisco Wireless Controller (z.B. WLC 5508 o.ä.) die Link Aggregation (LAG) unterstützten, muss die entsprechende Funktion aktiviert werden. Dies ist nur über die WLC-CLI und nicht über die GUI möglich. Setzt dazu einfach:

config ap lag-mode support enable

Die Änderungen erfordern keinen Neustart des Controllers! Ob der LAG-Modus für die Access Points bereits aktiviert ist, kann über folgenden Befehl geprüft werden:

show ap lag-mode

Nachdem der Modus aktiviert wurde, kann der einzelne Access Point (über den Controller) mit LAG-Konfiguration versehen werden:

config ap lag-mode support enable 'Name des WAP'

Diese Änderungen resultieren in einem Neustart des Wireless Access Points!

 

Konfiguration der Switchports

Nachdem die Änderungen am Access Point erledigt sind, müssen die entsprechenden Access Ports des jeweiligen Switches auf der Gegenseite angepasst werden. Die Switches müssen LACP unterstützen und im besten Falle den Lastenausgleichs-Algorithmus “src-dst-port”. Cisco Switches der Klassen 2960-S/-X, 3850-X, 3650-X bzw. 4500/6500 sollten diesen Modus ohne weiteres unterstützen. Bei den kleineren Serien könnte es lediglich an der Anzahl der konfigurierbaren Port Channel Interfaces scheitern. Die 2960CX 8-Port-Geräte unterstützen beispielsweise lediglich sechs Port Channel.

Folgende Konfiguration dazu als Beispiel:

interface GigabitEthernet1/0/1
  desc Wireless Access Point Ethernet
  switchport mode access
  switchport access vlan 100
  channel-group 10 mode active
  channel-protocol lacp

interface GigabitEthernet1/0/2
  desc Wireless Access Point AUX
  switchport mode access
  switchport access vlan 100
  channel-group 10 mode active
  channel-protocol lacp
 
interface Port-channel10
  desc Wireless Access Point Port Channel
  switchport mode access
  switchport access vlan 100

 

Best Practice

Etwas tückisch ist die Einrichtung dennoch. Werden die physischen Verbindungen gesteckt, obwohl der Access Point oder die Switchports noch nicht vorbereitet sind, besteht das Risiko von Spanning-Tree Loops. Andersherum ist der Access Point nicht über den Controller händelbar. Folgender Ablaufplan sollte daher Abhilfe schaffen:

  1. Aktivieren von AP-LAG auf dem Wireless Controller
  2. Vorbereiten des Port Channel Interface auf dem Switch
  3. Konfiguration des ersten Switchports als Standalone-Port
  4. Konfiguration des zweiten Switchport als Mitglied des Port Channel und shutdown!
  5. Physisches Verbinden des Access Point mit dem Switch
  6. Registrieren des Access Points am Wireless Controller inkl. Standard-Konfiguration oder Software-Updates etc.
  7. Konfiguration von AP-LAG auf dem entsprechenden Access Point (inkl. Neustart)
  8. Möglichst parallel: Aktivieren des zweiten Switchports und Konfiguration des ersten Switchports als Mitglied des Port Channel

Anschließend sollte der Access Point beide Ethernet-Schnittstellen als Uplink zum Switch nutzen können. Der Drahtlos-Datenrate von über 1Gbit/s stehen nur noch Wände, aber keine Techniken mehr im Wege! ;-)

Für die Troubleshooter noch der Hinweis: Mittels der folgenden Befehle kann überprüft werden, ob der Port Channel funktionsfähig ist.

Wireless Controller CLI:

show ap config general 'Name des WAP'

  AP LAG Configuration Status ..................... Enabled
  LAG Support for AP .............................. Yes

Switch CLI:

show etherchannel 10 summary

  Flags: D - down P - bundled in port-channel
   I - stand-alone s - suspended
   H - Hot-standby (LACP only)
   R - Layer3 S - Layer2
   U - in use N - not in use, no aggregation
   f - failed to allocate aggregator

   M - not in use, minimum links not met
   m - not in use, port not aggregated due to minimum links not met
   u - unsuitable for bundling
   w - waiting to be aggregated
   d - default port

   A - formed by Auto LAG

  Number of channel-groups in use: 3
  Number of aggregators: 3

  Group Port-channel Protocol Ports
  ------+-------------+-----------+-----------------------------------------------
  10    Po10(SU)     LACP     Gi1/0/1(P) Gi1/0/2(P)

Über die Wireless Controller GUI sind bei erfolgreicher Konfiguration ebenfalls beide Interfaces sichtbar, aktiv und übertragen Traffic.

Über den Autor

Jochen Reinecke administrator

Jochen Reinecke (26 Jahre), beschäftigt sich als leidenschaftlicher Systemingenieur für Netzwerkarchitektur seit über 10 Jahren mit Themen rund um Netzwerke, Firewalling, IT-Sicherheit, Compute, Storage, WiFi und Voice. Neben seinem beruflichen Abschluss als "Staatl. gepr. Techniker Fachrichtung Informatik" ist er unter anderem "Cisco Certified Network Associate (CCNA)" und "Microsoft Certified Solutions Expert (MCSE)" für "Cloud Platform and Infrastructure" sowie "Producitivity". Seit einigen Jahren engagiert er sich darüber hinaus für bitblick.de und veröffentlicht Beiträge für die Microsoft TechNet und andere Online-Plattformen. Die (knappe) Freizeit verbringt er mit der Familie, bei „zu wenig" Sport und dem nebenberuflichem Studium der Diplom-Wirtschaftsinformatik.

Schreibe eine Antwort

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.